宝塔Linux面板安装Composer依赖管理工具

发布于 2020-04-26  1.9k 次阅读


前言

跑了个项目,要用到Composer,于是网上找教程怎么安装,记录一下安装过程。

方法

1、删除禁用函数

找到PHP管理,点击禁用函数,将putenv删除。

2、安装

打开SSH终端,依次执行以下命令。

composer config -g repo.packagist composer https://packagist.phpcomposer.com
composer self-update #升级版本
composer clear #清除缓存

阿里备用源:

composer config repo.packagist composer https://mirrors.aliyun.com/composer/

安装完成后,可输入命令composer --version查看Composer版本。

多版本PHP共存的处理

网上教程说宝塔面板是支持多版本PHP共存的,需要把其他PHP版本禁用的putenv函数删除才可正常安装,但我实际安装的时候,发现即使其他版未开启这个函数,依旧可以安装Composer,但保险起见,建议开启所有PHP版本的putenv函数

参考

《linux宝塔面板安装composer的方法》


这短短的一生,我们最终都会失去。